Flash Player < 11.7.700.279 / Buffer Overflow (APSB14-13)

High Nessus Network Monitor Plugin ID 8805


The remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by a buffer overflow vulnerability.


Versions of Adobe Flash player prior to 11.7.700.279 / are outdated and thus unpatched for an overflow condition in the pixel bender component. The issue is triggered as user-supplied input is not properly validated. With a specially crafted SWF file, a context-dependent attacker can cause a buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (CVE-2014-0515)


Upgrade to Adobe Flash Player version or later. If 13.x cannot be obtained, 11.7.700.279 has also been patched for this vulnerability.

See Also



Plugin Details

Severity: High

ID: 8805

Family: Web Clients

Published: 2015/07/10

Modified: 2016/01/19

Dependencies: 5158

Nessus ID: 73740, 73741

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 8.1

Temporal Score: 7.7


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2014/05/08

Vulnerability Publication Date: 2014/04/28

Exploitable With

Metasploit (Adobe Flash Player Shader Buffer Overflow)

Reference Information

CVE: CVE-2014-0515

BID: 67092