Flash Player <= 11.7.700.275 / Pixel Bender Component Buffer Overflow (APSB14-13)

High Nessus Plugin ID 73740


The remote Windows host has a browser plugin that is affected by a buffer overflow vulnerability.


According to its version, the instance of Flash Player installed on the remote Windows host is equal or prior to 11.7.700.275 / 11.8.x / 11.9.x / 12.x / It is, therefore, potentially affected by a buffer overflow vulnerability due to improper user input validation in the Pixel Bender component. An attacker could cause a buffer overflow with a specially crafted SWF file, resulting in arbitrary code execution.


Upgrade to Adobe Flash Player version 11.7.700.279 / or later.

See Also



Plugin Details

Severity: High

ID: 73740

File Name: flash_player_apsb14-13.nasl

Version: $Revision: 1.11 $

Type: local

Agent: windows

Family: Windows

Published: 2014/04/28

Modified: 2017/05/16

Dependencies: 28211

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/04/28

Vulnerability Publication Date: 2014/04/28

Exploitable With

Core Impact

Metasploit (Adobe Flash Player Shader Buffer Overflow)

Reference Information

CVE: CVE-2014-0515

BID: 67092

OSVDB: 106347