Samba 4.x < 4.0.21 / 4.1.x < 4.1.11 nmbd Remote Code Execution

high Nessus Network Monitor Plugin ID 8759
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote version of Samba is outdated and affected by a remote code execution vulnerability.

Description

The version of Samba on the remote host is 4.x prior to 4.0.21 / 4.1.x prior to 4.1.11 and is affected by a flaw in the NetBIOS name services daemon (nmbd). This flaw may allow an attacker to execute arbitrary code as the superuser.

Solution

Upgrade to 4.0.21 / 4.1.11 or later.

See Also

http://www.samba.org/samba/security/CVE-2014-3560

http://www.samba.org/samba/history/samba-4.0.21.html

http://www.samba.org/samba/history/samba-4.1.11.html

Plugin Details

Severity: High

ID: 8759

Family: Samba

Published: 5/8/2015

Updated: 3/6/2019

Dependencies: 8741

Nessus ID: 76973

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:*

Patch Publication Date: 8/1/2014

Vulnerability Publication Date: 8/6/2014

Reference Information

CVE: CVE-2014-3560

BID: 69021