Samba 4.x < 4.0.21 / 4.1.11 nmbd Remote Code Execution

high Nessus Plugin ID 76973
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Samba server is affected by a remote code execution vulnerability.

Description

According to its banner, the version of Samba on the remote host is 4.x prior to 4.0.21 / 4.1.11. It is, therefore, affected by a flaw in the NetBIOS name services daemon (nmbd). This flaw may allow an attacker to execute arbitrary code as the superuser.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Install the patch referenced in the project's advisory or upgrade to 4.0.21 / 4.1.11 or later.

See Also

https://www.samba.org/samba/security/CVE-2014-3560.html

http://www.nessus.org/u?eca7bc26

Plugin Details

Severity: High

ID: 76973

File Name: samba_4_1_11.nasl

Version: 1.10

Type: remote

Family: Misc.

Published: 8/1/2014

Updated: 11/25/2019

Dependencies: smb_nativelanman.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2014-3560

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.9

Temporal Score: 5.8

Vector: AV:A/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 8/1/2014

Vulnerability Publication Date: 8/1/2014

Reference Information

CVE: CVE-2014-3560

BID: 69021