Samba 4.x < 4.0.24 / 4.1.x < 4.1.16 / 4.2.x < 4.2rc4 UF_SERVER_TRUST_ACCOUNT AD DC Privilege Escalation

High Nessus Network Monitor Plugin ID 8758

Synopsis

The remote version of Samba is outdated and affected by a privilege escalation vulnerability.

Description

The version of Samba on the remote host is 4.x prior to 4.0.24, 4.1.x prior to 4.1.16, or 4.2.x prior to 4.2rc4 and is affected by a flaw in the Active Directory Domain Controller (AD DC) component due to a failure to implement a required check on the 'UF_SERVER_TRUST_ACCOUNT' bit of the 'userAccountControl' attributes. This vulnerability could allow a remote, authenticated attacker to elevate privileges.

Solution

Upgrade to 4.0.24 / 4.1.16 / 4.2rc4 or later.

See Also

http://www.samba.org/samba/security/CVE-2014-8143

http://www.samba.org/samba/history/samba-4.0.24.html

http://www.samba.org/samba/history/samba-4.1.16.html

Plugin Details

Severity: High

ID: 8758

Family: Samba

Published: 2015/05/08

Modified: 2016/02/05

Dependencies: 8741

Nessus ID: 80916

Risk Information

Risk Factor: High

CVSSv2

Base Score: 8.5

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2015/01/15

Vulnerability Publication Date: 2015/01/16

Reference Information

CVE: CVE-2014-8143

BID: 72278