Samba 3.6.x < 3.6.24 / 4.0.x < 4.0.19 / 4.1.x < 4.1.9 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8757

Synopsis

The remote version of Samba is outdated and affected by multiple vulnerabilities.

Description

The version of Samba on the remote host is 3.6.x prior to 3.6.24, 4.0.x prior to 4.0.19, or 4.1.x prior to 4.1.9 and is affected by the following vulnerabilities :

- A denial of service flaw exists with 'nmbd'. A remote attacker, with a specially crafted packet, could cause the CPU to loop the same code segment, preventing further NetBIOS name services. (CVE-2014-0244)

- A denial of service flaw exists with 'smbd' when an authenticated client makes a non-unicode request for a valid unicode path. An invalid return code from the conversion of bad unicode to Windows character set can cause memory at an offset from the expected return buffer to be overwritten. This could allow a remote authenticated attacker to cause a denial of service. (CVE-2014-3493)

Solution

Upgrade to 3.6.24 / 4.0.19 / 4.1.9 or later.

See Also

http://www.samba.org/samba/security/CVE-2014-0244

http://www.samba.org/samba/security/CVE-2014-3493

http://www.samba.org/samba/history/samba-3.6.24.html

http://www.samba.org/samba/history/samba-4.0.19.html

http://www.samba.org/samba/history/samba-4.1.9.html

Plugin Details

Severity: Medium

ID: 8757

Family: Samba

Published: 2015/05/08

Modified: 2016/02/05

Dependencies: 8740, 8741

Nessus ID: 76202

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6

Temporal Score: 5.2

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5

Temporal Score: 4.8

Vector: CVSS3#AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2014/03/11

Vulnerability Publication Date: 2014/05/28

Reference Information

CVE: CVE-2014-0244, CVE-2014-3493

BID: 68148, 68150