Samba 3.6.x < 3.6.24 / 4.0.x < 4.0.19 / 4.1.x < 4.1.9 Multiple Vulnerabilities

Medium Nessus Plugin ID 76202


The remote Samba server is affected by multiple denial of service vulnerabilities.


According to its banner, the version of Samba on the remote host is 3.6.x prior to 3.6.24, 4.0.x prior to 4.0.19, or 4.1.x prior to 4.1.9. It is, therefore, affected by the following vulnerabilities :

- A denial of service flaw exists with 'nmbd'. A remote attacker, with a specially crafted packet, could cause the CPU to loop the same code segment, preventing further NetBIOS name services. (CVE-2014-0244)

- A denial of service flaw exists with 'smbd' when an authenticated client makes a non-unicode request for a valid unicode path. An invalid return code from the conversion of bad unicode to Windows character set can cause memory at an offset from the expected return buffer to be overwritten. This could allow a remote authenticated attacker to cause a denial of service.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Install the patch referenced in the project's advisory or upgrade to 3.6.24 / 4.0.19 / 4.1.9 or later.

See Also

Plugin Details

Severity: Medium

ID: 76202

File Name: samba_4_1_9.nasl

Version: $Revision: 1.3 $

Type: remote

Family: Misc.

Published: 2014/06/24

Modified: 2016/06/16

Dependencies: 10785

Risk Information

Risk Factor: Medium


Base Score: 6

Temporal Score: 5.2

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/06/23

Vulnerability Publication Date: 2014/06/23

Reference Information

CVE: CVE-2014-0244, CVE-2014-3493

BID: 68148, 68150

OSVDB: 108347, 108348