Samba 3.5.x / 3.6.x < 3.6.25 / 4.0.x < 4.0.25 / 4.1.x < 4.1.17 / 4.2.x < 4.2rc5 TALLOC_FREE() RCE

Critical Nessus Network Monitor Plugin ID 8753

Synopsis

The remote version of Samba is outdated and affected by a remote code execution vulnerability.

Description

The version of Samba running on the remote host is 3.5.x prior to 3.5.22, 3.6.x prior to 3.6.25, 4.0.x prior to 4.0.25, 4.1.x prior to 4.1.17, or 4.2.x prior to 4.2rc5 and is affected by a remote code execution vulnerability in the TALLOC_FREE() function of 'rpc_server/netlogon/srv_netlog_nt.c'. A remote attacker, using a specially crafted sequence of packets followed by a subsequent anonymous netlogon packet, can execute arbitrary code as the root user.

Solution

Upgrade to 3.6.25 / 4.0.25 / 4.1.17 / 4.2rc5 or later.

See Also

http://www.samba.org/samba/security/CVE-2015-0240

http://www.samba.org/samba/history/samba-3.6.25.html

http://www.samba.org/samba/history/samba-4.0.25.html

http://www.samba.org/samba/history/samba-4.1.17.html

Plugin Details

Severity: Critical

ID: 8753

Family: Samba

Published: 2015/05/08

Modified: 2016/01/19

Dependencies: 8740, 8741

Nessus ID: 81485

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2015/02/23

Vulnerability Publication Date: 2015/02/23

Reference Information

CVE: CVE-2015-0240

BID: 72711

IAVA: 2015-A-0042