Samba 3.5.x < 3.5.22 / 3.6.x < 3.6.25 / 4.0.x < 4.0.25 / 4.1.x < 4.1.17 TALLOC_FREE() RCE

Critical Nessus Plugin ID 81485


The remote Samba server is affected by a remote code execution vulnerability.


According to its banner, the version of Samba running on the remote host is 3.5.x prior to 3.5.22, 3.6.x prior to 3.6.25, 4.0.x prior to 4.0.25, or 4.1.x prior to 4.1.17. It is, therefore, affected by a remote code execution vulnerability in the TALLOC_FREE() function of 'rpc_server/netlogon/srv_netlog_nt.c'. A remote attacker, using a specially crafted sequence of packets followed by a subsequent anonymous netlogon packet, can execute arbitrary code as the root user.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Samba 3.6.25 / 4.0.25 / 4.1.17 or later. Alternatively, install the patch or apply the workaround referenced in the vendor advisory.

See Also

Plugin Details

Severity: Critical

ID: 81485

File Name: samba_4_1_17.nasl

Version: $Revision: 1.9 $

Type: remote

Family: Misc.

Published: 2015/02/24

Modified: 2016/06/16

Dependencies: 10785

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/02/23

Vulnerability Publication Date: 2015/02/23

Reference Information

CVE: CVE-2015-0240

BID: 72711

OSVDB: 118637