Flash Player <= 16.0.0.287 Multiple Vulnerabilities (APSB15-03)

High Nessus Network Monitor Plugin ID 8659

Synopsis

The remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.

Description

Versions of Adobe Flash player equal or prior to 16.0.0.287 are outdated and thus unpatched for the following vulnerabilities :

- A use-after-free error exists that allows an attacker to crash the application or execute arbitrary code. (CVE-2015-0311)

- A double-free error exists that allows an attacker to crash the application or possibly execute arbitrary code. (CVE-2015-0312)

Solution

Upgrade to Adobe Flash Player version 16.0.0.296 or later.\n\nAlternatively, Adobe has made version 13.0.0.264 available for those installs that cannot be upgraded to 16.x.

See Also

http://helpx.adobe.com/security/products/flash-player/apsb15-03.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: High

ID: 8659

Family: Web Clients

Published: 2015/03/27

Modified: 2016/01/19

Dependencies: 5158

Nessus ID: 80998

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.7

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2015/01/22

Vulnerability Publication Date: 2015/01/21

Exploitable With

Metasploit (Adobe Flash Player ByteArray UncompressViaZlibVariant Use After Free)

Reference Information

CVE: CVE-2015-0311, CVE-2015-0312

BID: 72283, 72343