Flash Player <= 16.0.0.287 Unspecified Code Execution (APSA15-01 / APSB15-03)

High Nessus Plugin ID 80998

Synopsis

The remote Windows host has a browser plugin that is affected by multiple code execution vulnerabilities.

Description

According to its version, the Adobe Flash Player installed on the remote Windows host is equal or prior to 16.0.0.287. It is, therefore, affected by the following vulnerabilities :

- A use-after-free error exists that allows an attacker to crash the application or execute arbitrary code.
(CVE-2015-0311)

- A double-free error exists that allows an attacker to crash the application or possibly execute arbitrary code. (CVE-2015-0312)

Solution

Upgrade to Adobe Flash Player version 16.0.0.296 or later.

Alternatively, Adobe has made version 13.0.0.264 available for those installations that cannot be upgraded to 16.x.

See Also

https://helpx.adobe.com/security/products/flash-player/apsa15-01.html

https://helpx.adobe.com/security/products/flash-player/apsb15-03.html

http://www.nessus.org/u?0cb17c10

https://www.adobe.com/products/flashplayer/distribution3.html

Plugin Details

Severity: High

ID: 80998

File Name: flash_player_apsa15-01.nasl

Version: 1.20

Type: local

Agent: windows

Family: Windows

Published: 2015/01/26

Updated: 2018/07/11

Dependencies: 28211

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/01/22

Vulnerability Publication Date: 2015/01/21

Exploitable With

Core Impact

Metasploit (Adobe Flash Player ByteArray UncompressViaZlibVariant Use After Free)

Reference Information

CVE: CVE-2015-0311, CVE-2015-0312

BID: 72283, 72343