Flash Player <= 184.108.40.206 Multiple Vulnerabilities (APSB15-01)
High Nessus Network Monitor Plugin ID 8657
SynopsisThe remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.
DescriptionVersions of Adobe Flash player equal or prior to 220.127.116.11 are outdated and thus unpatched for the following vulnerabilities :
- An unspecified improper file validation issue. (CVE-2015-0301)
- An unspecified information disclosure vulnerability, which can be exploited to capture keystrokes. (CVE-2015-0302)
- Multiple memory corruption vulnerabilities allow an attacker to execute arbitrary code. (CVE-2015-0303, CVE-2015-0306)
- Multiple heap-based buffer overflow vulnerabilities that can be exploited to execute arbitrary code. (CVE-2015-0304, CVE-2015-0309)
- An unspecified type confusion vulnerability that can lead to code execution. (CVE-2015-0305)
- An out-of-bounds read vulnerability that can be exploited to leak memory addresses. (CVE-2015-0307)
- A use-after-free vulnerability that results in arbitrary code execution. (CVE-2015-0308)
SolutionUpgrade to Adobe Flash Player version 18.104.22.1687 or later.\n\nAlternatively, Adobe has made version 22.214.171.1240 available for those installs that cannot be upgraded to 16.x.