VLC Media Player 2.x < 2.1.2 Buffer Overflow

High Nessus Network Monitor Plugin ID 8651

Synopsis

The remote host contains a media application that is affected by a buffer overflow vulnerability.

Description

The version of VLC media player installed on the remote host is earlier than 2.1.2. As such, it reportedly includes a version of Live Networks' Live555 Streaming Media library earlier than 2013.11.29. A buffer overflow vulnerability in the 'parseRTSPRequestString()' function in that library exists that could lead to a program crash or arbitrary code execution when handling a specially crafted RTSP message.

Solution

Upgrade to VLC Media Player version 2.1.2 or later.

See Also

http://www.nessus.org/u?011ac987

http://www.live555.com/liveMedia/public/changelog.txt

Plugin Details

Severity: High

ID: 8651

Family: Web Clients

Published: 2016/04/22

Modified: 2016/12/06

Dependencies: 9797

Nessus ID: 72279

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Patch Publication Date: 2013/12/10

Vulnerability Publication Date: 2013/11/29

Reference Information

CVE: CVE-2013-6933, CVE-2013-6934

BID: 65131, 65139