VLC 2.x < 2.1.2 parseRTSPRequestString Function RTSP Command Parsing Overflow

High Nessus Plugin ID 72279


The remote Windows host contains a media player that is affected by a buffer overflow vulnerability.


The version of VLC media player installed on the remote host is earlier than 2.1.2. As such, it reportedly includes a version of Live Networks' Live555 Streaming Media library earlier than 2013.11.29. A buffer overflow vulnerability in the 'parseRTSPRequestString()' function in that library exists that could lead to a program crash or arbitrary code execution when handling a specially crafted RTSP message.


Upgrade to version 2.1.2 or later.

See Also



Plugin Details

Severity: High

ID: 72279

File Name: vlc_2_1_2.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 2014/02/04

Updated: 2018/08/06

Dependencies: 31852

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/12/10

Vulnerability Publication Date: 2013/11/29

Exploitable With

Core Impact

Reference Information

CVE: CVE-2013-6933, CVE-2013-6934

BID: 65131, 65139