VLC 2.x < 2.1.2 parseRTSPRequestString Function RTSP Command Parsing Overflow

high Nessus Plugin ID 72279
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host contains a media player that is affected by a buffer overflow vulnerability.

Description

The version of VLC media player installed on the remote host is earlier than 2.1.2. As such, it reportedly includes a version of Live Networks' Live555 Streaming Media library earlier than 2013.11.29. A buffer overflow vulnerability in the 'parseRTSPRequestString()' function in that library exists that could lead to a program crash or arbitrary code execution when handling a specially crafted RTSP message.

Solution

Upgrade to version 2.1.2 or later.

See Also

http://www.nessus.org/u?011ac987

http://www.live555.com/liveMedia/public/changelog.txt

Plugin Details

Severity: High

ID: 72279

File Name: vlc_2_1_2.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 2/4/2014

Updated: 8/6/2018

Dependencies: vlc_installed.nasl

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/10/2013

Vulnerability Publication Date: 11/29/2013

Exploitable With

Core Impact

Reference Information

CVE: CVE-2013-6933, CVE-2013-6934

BID: 65131, 65139