VLC Media Player < 2.0.9 Buffer Overflow

Medium Nessus Network Monitor Plugin ID 8632

Synopsis

The remote host contains a media application that is affected by a buffer overflow vulnerability.

Description

The remote host is running VLC 2.x prior to 2.0.9 and is affected by a buffer overflow vulnerability in 'packetizer/mpeg4audio.c'.

Solution

Upgrade to VLC Media Player version 2.0.9 or later.

See Also

http://www.videolan.org/developers/vlc-branch/NEWS

http://www.openwall.com/lists/oss-security/2013/10/01/2

Plugin Details

Severity: Medium

ID: 8632

Family: Web Clients

Published: 2016/04/22

Modified: 2016/12/06

Dependencies: 9797

Nessus ID: 72279

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Patch Publication Date: 2013/08/25

Vulnerability Publication Date: 2013/09/30

Reference Information

CVE: CVE-2013-4388

BID: 62724