PHP 5.4.x < 5.4.36 / 5.5.x < 5.5.20 / 5.6.x < 5.6.4 Use-After-Free

High Nessus Network Monitor Plugin ID 8608


The remote web server uses an outdated version of PHP, leaving it vulnerable to several issues.


PHP versions earlier than 5.6.4, 5.5.20, and 5.4.36 are exposed to a use-after-free vulnerability in the 'process_nested_data' function in 'ext/standard/'. This allows remote attackers to execute arbitrary code via a crafted unserialize call that leverages improper handling of duplicate keys within the serialized properties of an object. (Bug 68594)


Apply the vendor's patch, or upgrade to the latest version. These issues have been fixed in versions 5.6.4, 5.5.20, and 5.4.36.

See Also

Plugin Details

Severity: High

ID: 8608

Family: Web Servers

Published: 2014/12/23

Modified: 2016/01/21

Dependencies: 8682

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.6


Temporal Vector: CVSS3#E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2014/12/22

Vulnerability Publication Date: 2014/12/20

Reference Information

CVE: CVE-2014-8142

BID: 71791