PHP 5.5.x < 5.5.20 'process_nested_data' RCE

high Nessus Plugin ID 80331
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by a remote code execution vulnerability.

Description

According to its banner, the version of PHP 5.5.x installed on the remote host is prior to 5.5.20. It is, therefore, affected by a use-after-free error in the 'process_nested_data' function within 'ext/standard/var_unserializer.re' due to improper handling of duplicate keys within the serialized properties of an object. A remote attacker, using a specially crafted call to the 'unserialize' method, can exploit this flaw to execute arbitrary code on the system.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.5.20 or later.

See Also

http://php.net/ChangeLog-5.php#5.5.20

https://bugs.php.net/bug.php?id=68594

http://www.nessus.org/u?88c4ed71

Plugin Details

Severity: High

ID: 80331

File Name: php_5_5_20.nasl

Version: 1.11

Type: remote

Family: CGI abuses

Published: 1/2/2015

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.6

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 12/18/2014

Vulnerability Publication Date: 12/18/2014

Reference Information

CVE: CVE-2014-8142

BID: 71791