SynopsisThe remote database server is potentially affected by multiple vulnerabilities.
DescriptionThe version of MySQL installed on the remote host is older than 5.5.39 or 5.6.20, and is thus unpatched for vulnerabilities within the following components:
- MyISAM temporary files, which may allow a local attacker to gain elevated privileges
- yaSSL, which contains an off-by-one overflow condition that can be leveraged for remote code execution
- MySQL admin password exposure after a password change
- mysqldump, which contains an overflow condition that can result in denial of service
- Replication, which may crash the database when handling overly large statements (versions 5.6.x only)
- InnoDB, which may crash when performing a DELETE operation (versions 5.6.x only)
SolutionUpgrade to version 5.5.39 / 5.6.20, or higher, to address these vulnerabilities.