MySQL 5.6.x < 5.6.20 Multiple Vulnerabilities (October 2014 CPU)

Medium Nessus Plugin ID 77670

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.20. It is, therefore, affected by errors in the following components :

- CLIENT:MYSQLADMIN
- CLIENT:MYSQLDUMP
- SERVER:CHARACTER SETS
- SERVER:DML
- SERVER:MEMORY STORAGE ENGINE
- SERVER:MyISAM
- SERVER:PRIVILEGES AUTHENTICATION PLUGIN API
- SERVER:REPLICATION ROW FORMAT BINARY LOG DML
- SERVER:SSL:OpenSSL
- SERVER:SSL:yaSSL

Solution

Upgrade to MySQL version 5.6.20 or later as referenced in the October 2014 Oracle Critical Patch Update advisory.

See Also

http://www.nessus.org/u?e5134a40

Plugin Details

Severity: Medium

ID: 77670

File Name: mysql_5_6_20.nasl

Version: 1.16

Type: remote

Family: Databases

Published: 2014/09/12

Updated: 2018/11/15

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/09/11

Vulnerability Publication Date: 2014/07/31

Exploitable With

Core Impact

Reference Information

CVE: CVE-2012-5615, CVE-2014-0224, CVE-2014-4274, CVE-2014-4287, CVE-2014-6463, CVE-2014-6474, CVE-2014-6478, CVE-2014-6484, CVE-2014-6489, CVE-2014-6495, CVE-2014-6505, CVE-2014-6530, CVE-2014-6551, CVE-2014-6564, CVE-2015-0391

BID: 56766, 67899, 69732, 70448, 70455, 70462, 70486, 70489, 70496, 70511, 70516, 70517, 70525, 70532, 72205