Google Chrome < 35.0.1916.153 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 8289

Synopsis

The remote host is running an outdated web browser that contains multiple vulnerabilities.

Description

The version of Google Chrome installed on the remote host is a version prior to 35.0.1916.153 and is thus missing fixes for multiple vulnerabilities, some of which can be leveraged for remote code execution:

- A use-after-free vulnerability in the filesystem API (CVE-2014-3154)

- Out-of-bounds read in SPDY implementation (CVE-2014-3155)

- A buffer overflow vulnerability in clipboard (CVE-2014-3156)

- A heap-based buffer overflow in media (CVE-2014-3157)

Solution

Update the Chrome browser to 35.0.1916.153 or later.

See Also

http://googlechromereleases.blogspot.com/2014/06/stable-channel-update.html

Plugin Details

Severity: High

ID: 8289

File Name: 8289.prm

Family: Web Clients

Published: 2014/06/11

Modified: 2016/01/15

Dependencies: 4645

Nessus ID: 74434

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Patch Publication Date: 2014/06/10

Vulnerability Publication Date: 2014/06/10

Reference Information

CVE: CVE-2014-3157, CVE-2014-3156, CVE-2014-3155, CVE-2014-3154

BID: 67981, 67980, 67977, 67972

OSVDB: 107840, 107837, 107838, 107839