Apache HTTP Server < 2.4.8 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8165

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

Versions of Apache HTTP Server older than 2.4.8 are unpatched for the following vulnerabilities:

- A denial-of-service vulnerability in the mod_log_config module that can be triggered due to insufficient user-input sanitation when logging a cookie with an unassigned value (CVE-2014-0098)

- A denial-of-service vulnerability in the mod_dav module that can be triggered when tracking the length of CDATA that includes leading whitespace characters. (CVE-2013-6438)

Solution

Upgrade to Apache HTTP Server 2.4.8, or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.9

http://httpd.apache.org/security/vulnerabilities_24.html

Plugin Details

Severity: Medium

ID: 8165

File Name: 8165.prm

Family: Web Servers

Published: 2014/03/20

Modified: 2017/02/02

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 3.6

Temporal Score: 3.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Patch Publication Date: 2014/03/17

Vulnerability Publication Date: 2014/03/17

Reference Information

CVE: CVE-2013-6438, CVE-2014-0098

BID: 66303

OSVDB: 104580, 104579

IAVA: 2015-A-0149