Apache 2.2.x < 2.2.27 Multiple Vulnerabilities

Medium Nessus Plugin ID 73405

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of Apache 2.2.x running on the remote host is a version prior to 2.2.27. It is, therefore, potentially affected by the following vulnerabilities :

- A flaw exists with the 'mod_dav' module that is caused when tracking the length of CDATA that has leading white space. A remote attacker with a specially crafted DAV WRITE request can cause the service to stop responding.
(CVE-2013-6438)

- A flaw exists in 'mod_log_config' module that is caused when logging a cookie that has an unassigned value. A remote attacker with a specially crafted request can cause the service to crash. (CVE-2014-0098)

Note that Nessus did not actually test for these issues, but instead has relied on the version in the server's banner.

Solution

Upgrade to Apache version 2.2.27 or later. Alternatively, ensure that the affected modules are not in use.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.2.27

http://httpd.apache.org/security/vulnerabilities_22.html

Plugin Details

Severity: Medium

ID: 73405

File Name: apache_2_2_27.nasl

Version: 1.15

Type: remote

Family: Web Servers

Published: 2014/04/08

Updated: 2018/09/17

Dependencies: 48204

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2014-0098

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/03/26

Vulnerability Publication Date: 2013/12/10

Reference Information

CVE: CVE-2013-6438, CVE-2014-0098

BID: 66303