Apple iOS 7.x < 7.0.6 / 6.x < 6.1.6 Information Disclosure

Medium Nessus Network Monitor Plugin ID 8135

Synopsis

The remote mobile host is running a version of Apple iOS that is missing an update related to the security of data in transit.

Description

According to its banner, the remote Apple iOS device is missing a security update. Versions of Apple iOS 6.x prior to 6.1.6, or 7.x prior to 7.0.6 are missing an update that restores missing validation steps when conducting a SSL/TLS session. This error could allow an attacker to spoof a server and modify or view sensitive information between it and the iOS device.

Solution

Upgrade to iOS version 7.0.6 or later. If 7.x cannot be obtained for your mobile device, 6.1.6 is also patched for these vulnerabilities.

See Also

http://support.apple.com/kb/HT6148

http://www.nessus.org/u?3bb60f78

http://www.nessus.org/u?083b8493

http://www.wired.com/threatlevel/2014/02/gotofail

https://www.imperialviolet.org/2014/02/22/applebug.html

Plugin Details

Severity: Medium

ID: 8135

Published: 2014/02/25

Modified: 2018/09/16

Dependencies: 8637

Nessus ID: 72666

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 5.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:apple:iphone_os

Patch Publication Date: 2014/02/21

Vulnerability Publication Date: 2014/02/21

Reference Information

CVE: CVE-2014-1266

BID: 65738