Apple iOS 6.x < 6.1.6 'SSLVerifySignedServerKeyExchange' Certificate Validation Weakness

Medium Nessus Plugin ID 72666

Synopsis

The version of iOS running on the mobile device is affected by a certificate validation weakness.

Description

The mobile device is running a version of iOS that is 6.x prior to version 6.1.6. It is, therefore, prone to an SSL certificate validation weakness. This error could allow an attacker to spoof a server and obtain sensitive information or modify secure content.

Solution

Upgrade to Apple iOS 6.1.6 or later.

See Also

https://www.imperialviolet.org/2014/02/22/applebug.html

http://comments.gmane.org/gmane.comp.security.patch-managment/4004

https://support.apple.com/en-us/HT202920

https://www.securityfocus.com/archive/1/531229/30/0/threaded

Plugin Details

Severity: Medium

ID: 72666

File Name: apple_ios_616_check.nbin

Version: 1.46

Type: local

Published: 2014/02/24

Modified: 2018/11/28

Dependencies: 60033

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:apple:iphone_os

Required KB Items: mdm/dependency/unlocked

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/02/21

Vulnerability Publication Date: 2014/02/21

Reference Information

CVE: CVE-2014-1266

BID: 65738

APPLE-SA: APPLE-SA-2014-02-21-1