CUPS < 1.7.1 Local Privilege Escalation Vulnerability

Low Nessus Network Monitor Plugin ID 8097

Synopsis

The remote host is running a program that is vulnerable to privilege escalation.

Description

CUPS is a *nix-based network printing program. Versions of CUPS earlier than 1.7.1 may contain a flaw in the lppasswd program due to incorrect use of settings from the '~/.cups/client.conf' file.

Solution

Upgrade to CUPS 1.7.1 or later.

See Also

http://freecode.com/projects/cups/releases/360519

http://www.cups.org/blog.php?L704

http://www.cups.org/str.php?L4319

Plugin Details

Severity: Low

ID: 8097

Family: Web Clients

Published: 2010/01/31

Updated: 2019/03/06

Nessus ID: 71977

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 1.2

Temporal Score: 1

Vector: CVSS2#AV:L/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 2.8

Temporal Score: 2.7

Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:cups:cups

Patch Publication Date: 2013/12/21

Vulnerability Publication Date: 2013/12/21

Reference Information

CVE: CVE-2013-6891

BID: 64985