CUPS 1.6.x >= 1.6.4 / 1.7.x < 1.7.1 lppasswd Information Disclosure

low Nessus Plugin ID 71977
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote print service is potentially affected by an information disclosure vulnerability.


According to its banner, the version of CUPS installed on the remote host is 1.6.x greater or equal to 1.6.4 or 1.7.x earlier than 1.7.1.
It is, therefore, potentially affected by an information disclosure vulnerability related to the 'lppasswd' binary, setuid settings, and the use of '~/.cups/client.conf' files that could allow a local attacker to obtain contents from arbitrary files in certain configurations.


Upgrade to CUPS version 1.7.1 or later, or apply the vendor patch.

See Also

Plugin Details

Severity: Low

ID: 71977

File Name: cups_1_7_1.nasl

Version: 1.9

Type: remote

Family: Misc.

Published: 1/15/2014

Updated: 11/26/2019

Dependencies: http_version.nasl, cups_1_3_5.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2013-6891


Risk Factor: Low

Score: 3.4


Risk Factor: Low

Base Score: 1.2

Temporal Score: 0.9

Vector: AV:L/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:cups

Required KB Items: www/cups, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 1/8/2014

Vulnerability Publication Date: 1/8/2014

Reference Information

CVE: CVE-2013-6891

BID: 64985