Apache Tomcat 9.0.x < 9.0.8 Denial of Service Vulnerability

medium Nessus Network Monitor Plugin ID 700706
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote Apache Tomcat server is affected by a denial of service vulnerability.


A denial of service (DoS) vulnerability exists in Apache Tomcat, in versions between 9.0.0.M1 and 9.0.7 (inclusive), due to improper overflow handling in the UTF-8 decoder component. An unauthenticated, remote attacker can exploit this issue, to cause the application to stop responding.


Upgrade to Apache Tomcat version 9.0.8 or later.

See Also


Plugin Details

Severity: Medium

ID: 700706

Family: Web Servers

Published: 5/13/2019

Updated: 5/13/2019

Nessus ID: 122447

Risk Information


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 5/3/2018

Vulnerability Publication Date: 7/22/2018

Reference Information

CVE: CVE-2018-1336

BID: 104898