Apache Tomcat 9.0.0.M1 < 9.0.8 Denial of Service Vulnerability

Medium Nessus Plugin ID 122447


The remote Apache Tomcat server is affected by a denial of service vulnerability


A denial of service (DoS) vulnerability exists in Apache Tomcat, in versions between 9.0.0.M1 and 9.0.7 (inclusive), due to improper overflow handling in the UTF-8 decoder component. An unauthenticated, remote attacker can exploit this issue, to cause the application to stop responding.


Upgrade to Apache Tomcat version 9.0.8 or later.

See Also


Plugin Details

Severity: Medium

ID: 122447

File Name: tomcat_9_0_8.nasl

Version: 1.1

Type: remote

Family: Web Servers

Published: 2019/02/27

Updated: 2019/02/27

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-1336

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Patch Publication Date: 2018/05/03

Vulnerability Publication Date: 2018/07/22

Reference Information

CVE: CVE-2018-1336

BID: 104898