Apache Tomcat 8.0.x < 8.5.40 Remote Code Execution Vulnerability (Windows)

high Nessus Network Monitor Plugin ID 700698

Synopsis

The remote Windows Apache Tomcat server is affected by a remote code execution vulnerability.

Description

The version of Tomcat installed on the remote Windows host is prior to 8.5.40. It is, therefore, affected by a remote code execution vulnerability due to a bug in the way the JRE passes command line arguments to Windows. An unauthenticated, remote attacker can exploit this to execute arbitrary commands. Additionally, it is affected by a cross-site (XSS) scripting vulnerability as the SSI printenv command echoes user provided data without proper escaping.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 8.5.40 or later.

See Also

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.40

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.40,https://github.com/apache/tomcat/commit/5bc4e6d

Plugin Details

Severity: High

ID: 700698

Family: Web Servers

Published: 5/13/2019

Updated: 5/13/2019

Nessus ID: 124064

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 4/13/2019

Vulnerability Publication Date: 3/3/2019

Reference Information

CVE: CVE-2019-0232

BID: 107906

IAVB: 2019-B-0027