Apache Tomcat 7.0.0 < 7.0.94 Remote Code Execution Vulnerability (Windows)

high Nessus Plugin ID 124064


The remote Windows Apache Tomcat server is affected by a remote code execution vulnerability


The version of Tomcat installed on the remote Windows host is prior to 7.0.94. It is, therefore, affected by a remote code execution vulnerability due to a bug in the way the JRE passes command line arguments to Windows. An unauthenticated, remote attacker can exploit this to execute arbitrary commands. Additionally, it is affected by a cross-site (XSS) scripting vulnerability as the SSI printenv command echoes user provided data without proper escaping.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 7.0.94 or later.

See Also



Plugin Details

Severity: High

ID: 124064

File Name: tomcat_7_0_94.nasl

Version: 1.12

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 4/16/2019

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information


Risk Factor: High

Score: 8.4


Risk Factor: High

Base Score: 9.3

Temporal Score: 7.7

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:F/RL:OF/RC:C

CVSS Score Source: CVE-2019-0232


Risk Factor: High

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Host/OS

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/13/2019

Vulnerability Publication Date: 3/3/2019

Exploitable With

Metasploit (Apache Tomcat CGIServlet enableCmdLineArguments Vulnerability)

Reference Information

CVE: CVE-2019-0221, CVE-2019-0232

BID: 107906