Apache Tomcat 8.5.x < 8.5.34 Open Redirect Weakness

medium Nessus Network Monitor Plugin ID 700696

Synopsis

The remote Apache Tomcat server is affected by a open redirect vulnerability.

Description

The version of Apache Tomcat installed on the remote host is version 8.5.x prior to 8.5.34. It is, therefore, affected by a vulnerability that could allow a remote attacker to bypass security restrictions, caused by a missing host name verification when using TLS with the WebSocket client. An attacker could exploit this vulnerability to bypass security constraints to access restricted resources.

Solution

Upgrade to Apache Tomcat version 8.5.34 or later.

See Also

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.34

Plugin Details

Severity: Medium

ID: 700696

Family: Web Servers

Published: 5/13/2019

Updated: 5/13/2019

Nessus ID: 118036

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 9/19/2018

Vulnerability Publication Date: 10/3/2018

Reference Information

CVE: CVE-2018-11784