Apache Tomcat 8.5.x < 8.5.31 Denial of Service

medium Nessus Network Monitor Plugin ID 700694
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote Apache Tomcat server is affected by a denial of service vulnerability.


According to its self-reported version number, the Apache Tomcat instance listening on the remote host is 8.5.x earlier to 8.5.31. It is, therefore, affected by the following vulnerability:

- A denial of service (DoS) vulnerability exists in Tomcat due to improper overflow handling in the UTF-8 decoder. An unauthenticated, remote attacker can exploit this issue to cause an infinite loop in the decoder, leading to a denial of service condition.

Note that Nessus Network Monitor has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 8.5.31 or later.

See Also


Plugin Details

Severity: Medium

ID: 700694

Family: Web Servers

Published: 5/13/2019

Updated: 5/13/2019

Nessus ID: 121124

Risk Information


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 5/16/2018

Vulnerability Publication Date: 12/7/2017

Reference Information

CVE: CVE-2018-1336

BID: 104898