Apache Tomcat 7.0.x < 7.0.89 DoS

high Nessus Network Monitor Plugin ID 700679
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Apache Tomcat server is affected by vulnerability.

Description

The version of Apache Tomcat installed on the remote host is version 7.0.41 prior to 7.0.89. It is, therefore, affected by an improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a Denial of Service.

Solution

Update to Apache Tomcat version 7.0.89 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.89

Plugin Details

Severity: High

ID: 700679

Family: Web Servers

Published: 5/13/2019

Updated: 5/13/2019

Nessus ID: 111068

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 5/16/2018

Vulnerability Publication Date: 12/7/2017

Reference Information

CVE: CVE-2018-8014

BID: 104203