Apache Tomcat 8.5.0 < 8.5.32 Multiple Vulnerabilities

critical Nessus Plugin ID 111068
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Apache Tomcat server is affected multiple security vulnerabilities.

Description

The version of Apache Tomcat installed on the remote host is 8.5.x prior to 8.5.32. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to Apache Tomcat version 8.5.32 or later.

See Also

http://www.nessus.org/u?5070a438

http://www.nessus.org/u?d5ab19d6

Plugin Details

Severity: Critical

ID: 111068

File Name: tomcat_8_5_32.nasl

Version: 1.10

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 7/13/2018

Updated: 3/11/2020

Dependencies: tomcat_error_version.nasl, tomcat_win_installed.nbin, apache_tomcat_nix_installed.nbin

Risk Information

CVSS Score Source: CVE-2018-8014

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat

Exploit Ease: No known exploits are available

Patch Publication Date: 2/13/2018

Vulnerability Publication Date: 2/12/2018

Reference Information

CVE: CVE-2018-8014, CVE-2018-8034, CVE-2018-8037

BID: 104203