Apache Tomcat 8.0.x < 8.0.47 / 8.5.x < 8.5.23 RCE

high Nessus Network Monitor Plugin ID 700610
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is missing an Apache Tomcat patch update.

Description

The version of Apache Tomcat installed on the remote host is version 8.0.x prior to 8.0.47, 8.5.x prior to 8.5.23. It is, therefore, affected by an unspecified vulnerability when running with HTTP PUTs enabled (e.g. via setting the readonly initialization parameter of the Default to false) that makes it possible to upload a JSP file to the server via a specially crafted request. This JSP could then be requested and any code it contained would be executed by the server.

Solution

Update to Apache Tomcat version 8.5.23. If version 8.5.x cannot be obtained, 8.0.47 has also been patched for this vulnerability.

See Also

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.23

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.0.47

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.0.47,http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.23

Plugin Details

Severity: High

ID: 700610

Family: Web Servers

Published: 4/19/2019

Updated: 4/19/2019

Nessus ID: 103697

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 10/3/2017

Vulnerability Publication Date: 10/3/2017

Reference Information

CVE: CVE-2017-12617

BID: 100954