Apache Tomcat 8.0.0.RC1 < 8.0.47 Multiple Vulnerabilities

High Nessus Plugin ID 103697

Synopsis

The remote Apache Tomcat server is affected by a code execution vulnerability.

Description

The version of Apache Tomcat installed on the remote host is 8.0.0.RC1 or later but prior to 8.0.47. It is, therefore, affected by an unspecified vulnerability when running with HTTP PUTs enabled (e.g.
via setting the readonly initialization parameter of the Default to false) that makes it possible to upload a JSP file to the server via a specially crafted request. This JSP could then be requested and any code it contained would be executed by the server.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 8.0.47 or later.

See Also

http://www.nessus.org/u?4f047e41

Plugin Details

Severity: High

ID: 103697

File Name: tomcat_8_0_47.nasl

Version: 1.8

Type: remote

Family: Web Servers

Published: 2017/10/06

Updated: 2018/08/01

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/10/03

Vulnerability Publication Date: 2017/10/03

Exploitable With

Core Impact

Metasploit (Tomcat RCE via JSP Upload Bypass)

Elliot (Apache Tomcat for Windows HTTP PUT Method File Upload)

Reference Information

CVE: CVE-2017-12617

BID: 100954