OpenSSL 1.0.x < 1.0.2n DoS

Low Nessus Network Monitor Plugin ID 700523

Synopsis

The remote web server is running an outdated instance of OpenSSL and is affected by a Denial of Service (DoS) attack vector.

Description

According to its banner, the version of OpenSSL on the remote host is version 1.0.x prior to 1.0.2n. It is, therefore, affected by a DoS vulnerability that allows potential recovery of private key information or failure to properly encrypt data.

Solution

Upgrade OpenSSL to version 1.0.2n or higher

See Also

https://www.openssl.org/news/secadv/20171207.txt

Plugin Details

Severity: Low

ID: 700523

Family: Web Servers

Published: 2019/04/10

Updated: 2019/04/10

Dependencies: 5563

Nessus ID: 105291

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.6

Temporal Score: 1.9

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 3.7

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2017/12/07

Vulnerability Publication Date: 2017/12/07

Reference Information

CVE: CVE-2017-3737

BID: 102103, 102118