OpenSSL 1.0.2 < 1.0.2n Multiple Vulnerabilities

Low Nessus Plugin ID 105291

Synopsis

A service running on the remote host is affected by multiple vulnerabilities.

Description

According to its banner, the version of OpenSSL running on the remote host is 1.0.x prior to 1.0.2n. It is, therefore, affected by multiple vulnerabilities that allow potential recovery of private key information or failure to properly encrypt data.

Solution

Upgrade to OpenSSL version 1.0.2n or later.

See Also

https://www.openssl.org/news/secadv/20171207.txt

Plugin Details

Severity: Low

ID: 105291

File Name: openssl_1_0_2n.nasl

Version: 1.6

Type: remote

Family: Web Servers

Published: 2017/12/15

Updated: 2018/08/24

Dependencies: 57323

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.6

Temporal Score: 1.9

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 3.7

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/12/07

Vulnerability Publication Date: 2017/12/07

Reference Information

CVE: CVE-2017-3737, CVE-2017-3738

BID: 102103, 102118