Apple Safari < 12.0.3 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 700508

Synopsis

A web browser installed on the remote host is affected by multiple vulnerabilities.

Description

The version of Apple Safari installed on the remote host is prior to 12.0.3. It is, therefore, affected by the following vulnerabilities :

- Input-validation errors exist that allow memory corruption leading to arbitrary code execution. (CVE-2019-6212, CVE-2019-6215, CVE-2019-6216, CVE-2019-6217, CVE-2019-6226, CVE-2019-6227, CVE-2019-6233, CVE-2019-6234)

- Input-validation errors exist that allow an attacker to perform cross-site scripting attacks. (CVE-2019-6228, CVE-2019-6228)

Note that Nessus Network Monitor has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apple Safari version 12.0.3 or later.

See Also

https://support.apple.com/en-us/HT209449

http://www.nessus.org/u?3f718015

Plugin Details

Severity: High

ID: 700508

Family: Web Clients

Published: 2019/04/08

Updated: 2019/04/08

Dependencies: 3705

Nessus ID: 121388

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Patch Publication Date: 2018/01/22

Vulnerability Publication Date: 2018/01/22

Reference Information

CVE: CVE-2019-6212, CVE-2019-6215, CVE-2019-6216, CVE-2019-6217, CVE-2019-6226, CVE-2019-6227, CVE-2019-6228, CVE-2019-6229, CVE-2019-6233, CVE-2019-6234

BID: 106691, 106692, 106696, 106699