CVE-2019-6227

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

A memory corruption issue was addressed with improved memory handling. This issue is fixed in iOS 12.1.3, tvOS 12.1.2, watchOS 5.1.3, Safari 12.0.3, iTunes 12.9.3 for Windows, iCloud for Windows 7.10. Processing maliciously crafted web content may lead to arbitrary code execution.

References

http://www.securityfocus.com/bid/106696

https://security.gentoo.org/glsa/201903-12

https://support.apple.com/HT209443

https://support.apple.com/HT209447

https://support.apple.com/HT209448

https://support.apple.com/HT209449

https://support.apple.com/HT209450

https://support.apple.com/HT209451

Details

Source: MITRE

Published: 2019-03-05

Updated: 2020-08-24

Type: CWE-787

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (11 total)

IDNameProductFamilySeverity
700556Apple iOS < 12.1.3 Multiple Vulnerabilities (APPLE-SA-2019-1-22-1)Nessus Network MonitorMobile Devices
medium
700508Apple Safari < 12.0.3 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
high
122834GLSA-201903-12 : WebkitGTK+: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
122745openSUSE Security Update : webkit2gtk3 (openSUSE-2019-309)NessusSuSE Local Security Checks
high
122744openSUSE Security Update : webkit2gtk3 (openSUSE-2019-308)NessusSuSE Local Security Checks
high
122531SUSE SLED12 / SLES12 Security Update : webkit2gtk3 (SUSE-SU-2019:0511-1)NessusSuSE Local Security Checks
high
122474SUSE SLED15 / SLES15 Security Update : webkit2gtk3 (SUSE-SU-2019:0497-1)NessusSuSE Local Security Checks
high
122413FreeBSD : webkit-gtk -- Multiple vulnabilities (e3aacd6d-3d01-434c-9330-bc9efd40350f)NessusFreeBSD Local Security Checks
high
121473Apple iTunes < 12.9.3 Multiple Vulnerabilities (credentialed check)NessusWindows
critical
121388macOS : Apple Safari < 12.0.3 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
121331Apple iOS < 12.1.3 Multiple VulnerabilitiesNessusMobile Devices
high