Flash Player < 30.0.0.134 Multiple Vulnerabilities (APSB18-24)

High Nessus Network Monitor Plugin ID 700435

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by multiple attack vectors.

Description

Versions of Adobe Flash Player prior to 30.0.0.134 are unpatched, and therefore affected by multiple vulnerabilities :

- A type confusion vulnerability exists that could lead to arbitrary code execution in the context of the current user. (CVE-2018-5007)
- An out-of-bounds read vulnerability exists that could lead to information disclosure. (CVE-2018-5008)

Solution

Upgrade to Adobe Flash Player version 30.0.0.134 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-24.html

Plugin Details

Severity: High

ID: 700435

Family: Web Clients

Published: 2019/03/20

Updated: 2019/04/09

Dependencies: 5158

Nessus ID: 110979

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2018/07/10

Vulnerability Publication Date: 2018/07/10

Reference Information

CVE: CVE-2018-5007, CVE-2018-5008

BID: 104698