Flash Player < 29.0.0.140 Multiple Vulnerabilities (APSB18-08)

Critical Nessus Network Monitor Plugin ID 700432

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by multiple attack vectors.

Description

Versions of Adobe Flash Player prior to 29.0.0.140 are unpatched, and therefore affected by multiple vulnerabilities :

- A Use-After-Free vulnerability exists that could lead to arbitrary code execution. (CVE-2018-4932)
- Multiple out-of-bounds read vulnerabilities exist that could lead to information disclosure. (CVE-2018-4933, CVE-2018-4934, CVE-2018-4935, CVE-2018-4937)
- A heap overflow vulnerability exists that could lead to information disclosure. (CVE-2018-4936)

Solution

Upgrade to Adobe Flash Player version 29.0.0.140 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-08.html

Plugin Details

Severity: Critical

ID: 700432

Family: Web Clients

Published: 2019/03/20

Updated: 2019/04/09

Dependencies: 5158

Nessus ID: 108958

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2018/04/10

Vulnerability Publication Date: 2018/04/10

Reference Information

CVE: CVE-2018-4932, CVE-2018-4933, CVE-2018-4934, CVE-2018-4935, CVE-2018-4936, CVE-2018-4937