Flash Player < 27.0.0.170 RCE (APSB17-32)

High Nessus Network Monitor Plugin ID 700426

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by a remote code execution (RCE) attack vector.

Description

Versions of Adobe Flash Player prior to 27.0.0.170 are unpatched and therefore affected by an unspecified type confusion flaw that is caused by input not being properly validated. An unauthenticated, remote attacker can exploit this, by convincing a user to visit a website containing specially crafted Flash content, to trigger the vulnerability and potentially execute arbitrary code.

Solution

Upgrade to Adobe Flash Player version 27.0.0.170 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb17-32.html

Plugin Details

Severity: High

ID: 700426

Family: Web Clients

Published: 2019/03/20

Updated: 2019/04/09

Dependencies: 5158

Nessus ID: 103922

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2017/10/16

Vulnerability Publication Date: 2017/10/16

Reference Information

CVE: CVE-2017-11292

BID: 101286