Adobe Flash Player <= 27.0.0.159 Type Confusion Vulnerability (APSB17-32)

Medium Nessus Plugin ID 103922

Synopsis

The remote Windows host has a browser plugin installed that is affected by a type confusion vulnerability.

Description

The version of Adobe Flash Player installed on the remote Windows host is equal or prior to version 27.0.0.159. It is, therefore, affected by an unspecified type confusion flaw that is caused by input not being properly validated. An unauthenticated, remote attacker can exploit this, by convincing a user to visit a website containing specially crafted Flash content, to trigger the vulnerability and potentially execute arbitrary code.

Solution

Upgrade to Adobe Flash Player version 27.0.0.170 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb17-32.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: Medium

ID: 103922

File Name: flash_player_apsb17-32.nasl

Version: 1.7

Type: local

Agent: windows

Family: Windows

Published: 2017/10/18

Updated: 2019/11/12

Dependencies: 28211

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-11292

CVSS v2.0

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/10/16

Vulnerability Publication Date: 2017/10/16

Reference Information

CVE: CVE-2017-11292

BID: 101286