PHP 5.5.x < 5.5.1 xml.c Buffer Overflow

high Nessus Network Monitor Plugin ID 6999
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by a buffer overflow vulnerability.

Description

PHP versions earlier than 5.5.1 are potentially affected by a buffer overflow error that exists in the file 'ext/xml/xml.c'

Solution

Apply the vendor patch or upgrade to PHP version 5.5.1 or later.

See Also

https://bugs.php.net/bug.php?id=65236

http://www.php.net/ChangeLog-5.php#5.5.1

Plugin Details

Severity: High

ID: 6999

Family: Web Servers

Published: 8/26/2013

Updated: 3/6/2019

Dependencies: 8682

Nessus ID: 69348

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 7/18/2013

Vulnerability Publication Date: 7/10/2013

Reference Information

CVE: CVE-2013-4113

BID: 6112