PHP 5.5.x < 5.5.1 xml.c Buffer Overflow

medium Nessus Plugin ID 69348
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is potentially affected by a buffer overflow vulnerability.

Description

According to its banner, the version of PHP 5.5.x installed on the remote host is a version prior to 5.5.1. It is, therefore, potentially affected by a buffer overflow error that exists in the file 'ext/xml/xml.c'.

Note that this plugin does not attempt to exploit this vulnerability, but instead relies only on PHP's self-reported version number.

Solution

Apply the vendor patch or upgrade to PHP version 5.5.1 or later.

See Also

https://bugs.php.net/bug.php?id=65236

http://www.php.net/ChangeLog-5.php#5.5.1

Plugin Details

Severity: Medium

ID: 69348

File Name: php_5_5_1.nasl

Version: 1.14

Type: remote

Family: CGI abuses

Published: 8/14/2013

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2013-4113

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 7/18/2013

Vulnerability Publication Date: 7/10/2013

Reference Information

CVE: CVE-2013-4113

BID: 61128