PHP 5.5.x < 5.5.1 xml.c Buffer Overflow

High Nessus Plugin ID 69348


The remote web server uses a version of PHP that is potentially affected by a buffer overflow vulnerability.


According to its banner, the version of PHP 5.5.x installed on the remote host is a version prior to 5.5.1. It is, therefore, potentially affected by a buffer overflow error that exists in the file 'ext/xml/xml.c'.

Note that this plugin does not attempt to exploit this vulnerability, but instead relies only on PHP's self-reported version number.


Apply the vendor patch or upgrade to PHP version 5.5.1 or later.

See Also

Plugin Details

Severity: High

ID: 69348

File Name: php_5_5_1.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 2013/08/14

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2013/07/18

Vulnerability Publication Date: 2013/07/10

Reference Information

CVE: CVE-2013-4113

BID: 61128