PHP 5.5.x < 5.5.2 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 6997


The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


PHP versions earlier than 5.5.2 are affected by the following vulnerabilities :

- An error exists related to the 'Sessions' subsystem that can allow an attacker to hijack the session of another user. (CVE-2011-4718 / Bug #60491)

- An error exists related to certificate validation, the 'subjectAltName' field and certificates containing NULL bytes. This error can allow spoofing attacks. (CVE-2013-4248)


Apply the vendor patch or upgrade to PHP version 5.5.2 or later.

See Also

Plugin Details

Severity: Medium

ID: 6997

Family: Web Servers

Published: 8/21/2013

Updated: 3/6/2019

Nessus ID: 69402

Risk Information


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 8/15/2013

Vulnerability Publication Date: 12/2/2011

Reference Information

CVE: CVE-2013-4248, CVE-2011-4718

BID: 61776, 61929