PHP 5.5.x < 5.5.2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6997

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

PHP versions earlier than 5.5.2 are affected by the following vulnerabilities :

- An error exists related to the 'Sessions' subsystem that can allow an attacker to hijack the session of another user. (CVE-2011-4718 / Bug #60491)

- An error exists related to certificate validation, the 'subjectAltName' field and certificates containing NULL bytes. This error can allow spoofing attacks. (CVE-2013-4248)

Solution

Apply the vendor patch or upgrade to PHP version 5.5.2 or later.

See Also

https://bugs.php.net/bug.php?id=60491

http://www.php.net/ChangeLog-5.php#5.5.2

Plugin Details

Severity: Medium

ID: 6997

Family: Web Servers

Published: 2013/08/21

Modified: 2016/01/19

Dependencies: 8682

Nessus ID: 69402

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2013/08/15

Vulnerability Publication Date: 2011/12/02

Reference Information

CVE: CVE-2011-4718, CVE-2013-4248

BID: 61776, 61929