PHP 5.5.x < 5.5.3 Multiple Vulnerabilities

high Nessus Plugin ID 69402

Synopsis

The remote web server uses a version of PHP that is potentially affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.5.x installed on the remote host is a version prior to 5.5.3. It is, therefore, potentially affected by the following vulnerabilities :

- An error exists related to the 'Sessions' subsystem that can allow an attacker to hijack the session of another user. (CVE-2011-4718 / Bug #60491)

- An error exists related to certificate validation, the 'subjectAltName' field and certificates containing NULL bytes. This error can allow spoofing attacks.
(CVE-2013-4248)

Note that this plugin does not attempt to exploit these vulnerabilities, but instead relies only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.5.3 or later.

Note the 5.5.2 release contains an uninitialized memory read bug and a compile error that prevent proper operation.

See Also

https://bugs.php.net/bug.php?id=60491

http://www.php.net/ChangeLog-5.php#5.5.3

http://php.net/releases/5_5_3.php

Plugin Details

Severity: High

ID: 69402

File Name: php_5_5_2.nasl

Version: 1.14

Type: remote

Family: CGI abuses

Published: 8/21/2013

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 6.8

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2011-4718

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 8/15/2013

Vulnerability Publication Date: 12/2/2011

Reference Information

CVE: CVE-2011-4718, CVE-2013-4248

BID: 61776, 61929