PHP 5.4.x < 5.4.18 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 6996

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

PHP versions 5.4.x earlier than 5.4.18 are affected by the following vulnerabilities : - A heap corruption error exists in numerous functions in the file 'ext/xml/xml.c'. (CVE-2013-4113 / Bug #65236)

- An error exists related to certificate validation, the 'subjectAltName' field and certificates containing NULL bytes. This error can allow spoofing attacks. (CVE-2013-4248)

Solution

Apply the vendor patch or upgrade to PHP version 5.4.18 or later.

See Also

http://bugs.php.net/65236

http://www.php.net/ChangeLog-5.php#5.4.18

Plugin Details

Severity: High

ID: 6996

Family: Web Servers

Published: 2013/08/21

Modified: 2016/01/19

Dependencies: 8682

Nessus ID: 69401

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2013/08/15

Vulnerability Publication Date: 2013/07/10

Reference Information

CVE: CVE-2013-4113, CVE-2013-4248

BID: 61128, 61776