PHP 5.4.x < 5.4.19 Multiple Vulnerabilities
Medium Nessus Plugin ID 69401
SynopsisThe remote web server uses a version of PHP that is potentially affected by multiple vulnerabilities.
DescriptionAccording to its banner, the version of PHP 5.4.x installed on the remote host is a version prior to 5.4.19. It is, therefore, potentially affected by the following vulnerabilities :
- A heap corruption error exists in numerous functions in the file 'ext/xml/xml.c'. (CVE-2013-4113 / Bug #65236)
- An error exists related to certificate validation, the 'subjectAltName' field and certificates containing NULL bytes. This error can allow spoofing attacks.
Note that this plugin does not attempt to exploit these vulnerabilities, but instead relies only on PHP's self-reported version number.
SolutionUpgrade to PHP version 5.4.19 or later.
Note the 5.4.18 release contains an uninitialized memory read bug and a compile error that prevent proper operation.